Appendix A. Installing the Android SDK

This chapter covers

  • Meeting development environment requirements
  • Obtaining and installing Eclipse
  • Obtaining the Android SDK
  • Using the SDK and AVD Manager
  • Configuring the Android Development Tools for Eclipse

This appendix walks through the installation of Eclipse, the Android SDK, and the ADT plug-in for Eclipse. This appendix is meant to be a reference resource to assist in setting up the environment for Android application development. The topic of using the development tools is covered in chapter 2.

A.1. Development environment requirements

To develop Android applications, your computing environment must satisfy the minimum requirements. Android development is a quick-paced topic, with changes coming about very rapidly, so it’s a good idea to stay in tune with the latest developments from the Android development team at Google. You’ll find the latest information regarding supported platforms and requirements for Android Development Tools (ADT) at http://developer.android.com/sdk/requirements.html.

Compatible development environments for the sample applications in this book include:

  • Windows XP/Vista/Windows 7, Mac OS X 10.4.8 or later (Intel x86 only), Linux
  • Eclipse 3.4 (or later), including the JDT and Web Tools Platform, which are included in the Eclipse installation package
  • JDK and Java Runtime Environment (JRE) version 5 or 6
  • ADT plug-in for Eclipse

A.2. Obtaining and installing Eclipse

A.3. Obtaining and installing the Android SDK

A.4. Using the SDK and AVD Manager

A.5. Obtaining and installing the Eclipse plug-in

A.6. Configuring the Eclipse plug-in

sitemap